If your Roku device is interfering with Wi-Fi, how do you disable Wi-Fi direct on the device?


Environment

  • Roku
  • Wi-Fi
  • Residence Halls


Cause

Roku Wi-Fi-Direct operates on the same frequency as USD's Wi-Fi. Roku uses Wi-Fi-Direct to connect some remotes, which utilize and broadcast on the same channel that it receives internet. The result is that there will be interference, even on 5 GHz, causing other devices to either drop the signal intermittently or fail to connect or lower bandwidth.

Additionally, some Roku models have an interference mitigation feature that is enabled by default. This technology disrupts traffic to nearby Wi-Fi access points to improve the local signal. These features can affect the performance of USD's wireless network for everyone.


Resolution

Note: If your make or model is not listed please reference your user manual or vendor's website


Roku 2

  1. Open Roku home screen
  2. Choose Settings
  3. From the System submenu, select Advanced system settings
  4. Select Device Connect
  5. Select Disable Device Connect
  6. Done

Now you will not be able to see the Roku Wi-Fi Direct network.


Roku 3

  1. Startup the Roku Open the home screen
  2. Press these 10 buttons quickly: HOME-HOME-HOME-HOME-HOME-FFWD-PLAY-REWIND-PLAY-FFWD —
    *Note: The HOME button is the button with a picture of a house
  3. Select Wireless Secret Screen
  4. Select Interference
  5. Choose None
  6. Done

This should resolve the issue. You do NOT need to reboot the Roku.



Roku Device Connect on Smart TVs and Older Roku Devices

  1. Open the Settings screen of the Roku device
  2. Select System
  3. Select Advanced system settings
  4. Select Device connect
  5. Choose Disable Device Connect
  6. Done